Degraded Performance - Boost Dashboard

Incident Report for BenchPrep

Resolved

This incident has been resolved.
Posted Oct 23, 2025 - 09:42 CDT

Update

We are continuing to monitor progress, with full resolution expected soon
Posted Oct 23, 2025 - 08:23 CDT

Monitoring

We have implemented a fix and are monitoring progress
Posted Oct 22, 2025 - 17:01 CDT

Identified

The issue with Boost reporting has been identified and a fix is being implemented.
Posted Oct 22, 2025 - 12:21 CDT

Investigating

We are actively investigating an issue affecting Boost Reporting Dashboard. The Learning Application and other admin tools are not affected.
Posted Oct 21, 2025 - 14:15 CDT
This incident affected: Boost Reporting Dashboard.