Downgraded performance - ticketing sytsem

Incident Report for BenchPrep

Resolved

The issue has been resolved. Support tickets can be logged via https://support.benchprep.com/new/
Posted Mar 26, 2026 - 10:01 CDT

Investigating

We are currently investigating an issue with our 3rd party ticketing system. This does not affect any Admin or Learner facing applications.
If you are unable to submit a support ticket via https://support.benchprep.com/new/ you can send an email via help@benchprep.com
Posted Mar 26, 2026 - 09:37 CDT
This incident affected: Ticketing System.